Rachel Tobac

Apple warns of security flaw for iPhones, iPads and Macs

Security experts have advised users to update affected devices, the iPhone6S and later models. The flaw also affects some iPod models.

published on : 19th August 2022